RBC Express System Requirements

The following are the minimum system requirements for RBC Express. It is only acceptable to use official versions, which are unaltered from manufacturer specifications. Beta releases are not supported.

Operating Systems

Minimum Recommended Supported
Windows 7 Windows 8.1 Windows 7
Windows 8
Windows 8.1
Windows 10
Mac OS X 10.8 Mountain Lion Mac OS X 10.10 Yosemite Mac OS X 10.8 Mountain Lion
Mac OS X 10.9 Mavericks
Mac OS X 10.10 Yosemite

Web Browsers

Minimum Recommended Supported Download Browser
Windows OS
Internet Explorer 9 Internet Explorer 11 Internet Explorer 10
Internet Explorer 11
Microsoft Edge
Microsoft Explorer
Firefox 37 Firefox latest version Firefox latest version Mozilla Firefox
Google Chrome 39 Google Chrome latest version Google Chrome latest version Google Chrome
Mac OS
Safari 6.2.4 Safari 8.2.4 Safari latest version Safari
Firefox 37 Firefox latest version Firefox latest version Mozilla Firefox
Google Chrome 39 Google Chrome latest version Google Chrome latest version Google Chrome

Web Browser Plug-Ins

Minimum Recommended Supported Install Plug-In
Oracle Java 7u79 Oracle Java 7u79 or higher Oracle Java 7u79 or higher Oracle Java
Adobe Reader X Adobe Reader X Adobe Reader X or higher Adobe Reader